adeptviews 1.2.0+22

  • Readme
  • Changelog
  • Installing
  • 60

adeptviews #

A new Flutter project.

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

1.2.0+22 #

1.1.9+21 #

1.1.8+20 #

1.1.7+19 #

1.1.6+18 #

1.1.5+17 #

1.1.4+16 #

1.1.3+15 #

1.1.2+14 #

1.1.1+13 #

1.1.0+12 #

1.0.9+11 #

1.0.8+10 #

1.0.7+9 #

1.0.6+8 #

1.0.5+7 #

1.0.4+6 #

1.0.3+5 #

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  adeptviews: ^1.2.0+22

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:adeptviews/adeptviews.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
49
Health:
Code health derived from static analysis. [more]
91
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
60
Learn more about scoring.

We analyzed this package on Jun 4, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.2
  • pana: 0.13.8-dev
  • Flutter: 1.17.1

Health suggestions

Fix lib/src/dialog/nice_dialog.dart. (-1.49 points)

Analysis of lib/src/dialog/nice_dialog.dart reported 3 hints:

line 13 col 7: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: NiceDialog.type, NiceDialog.typeInfoColor, NiceDialog.typeWarningColor, NiceDialog.typeErrorColor, NiceDialog.typeMultipleOptionsColor, NiceDialog.backgroundColor, NiceDialog.elevation, NiceDialog.shape, NiceDialog.header, NiceDialog.headerColor, NiceDialog.headerIcon, NiceDialog.headerIconData, NiceDialog.headerIconSize, NiceDialog.headerIconColor, NiceDialog.headerPadding, NiceDialog.borderRadius, NiceDialog.title, NiceDialog.titleText, NiceDialog.titleColor, NiceDialog.content, NiceDialog.message, NiceDialog.messageColor, NiceDialog.btnOk, NiceDialog.btnOkText, NiceDialog.btnOkColor, NiceDialog.btnOkAction, NiceDialog.btnCancel, NiceDialog.btnCancelText, NiceDialog.btnCancelColor, NiceDialog.btnCancelAction, NiceDialog.btnNeutral, NiceDialog.btnNeutralText, NiceDialog.btnNeutralColor, NiceDialog.btnNeutralAction

line 118 col 48: 'title' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is headline6. This feature was deprecated after v1.13.8..

line 123 col 50: 'subtitle' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is subtitle2. This feature was deprecated after v1.13.8..

Fix lib/src/hint_view.dart. (-1.49 points)

Analysis of lib/src/hint_view.dart reported 3 hints:

line 4 col 7: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: HintView.text, HintView.textColor, HintView.textSize, HintView.iconData, HintView.iconDataColor, HintView.iconDataSize, HintView.textView, HintView.iconView, HintView.imageView, HintView.padding, HintView.dividerHeight, HintView.width, HintView.height

line 64 col 51: 'display1' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is headline4. This feature was deprecated after v1.13.8..

line 70 col 47: 'display1' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is headline4. This feature was deprecated after v1.13.8..

Fix lib/src/drawer/adept_drawer.dart. (-1 points)

Analysis of lib/src/drawer/adept_drawer.dart reported 2 hints:

line 70 col 43: The member 'setState' can only be used within instance members of subclasses of 'package:flutter/src/widgets/framework.dart'.

line 82 col 35: The member 'setState' can only be used within instance members of subclasses of 'package:flutter/src/widgets/framework.dart'.

Fix additional 18 files with analysis or formatting issues. (-5.50 points)

Additional issues in the following files:

  • lib/src/drop_down/adept_drop_down_button_form_field.dart (2 hints)
  • lib/src/button/adept_icon_button.dart (1 hint)
  • lib/src/drawer/drawer_item.dart (1 hint)
  • lib/src/drop_down/adept_drop_down_button.dart (1 hint)
  • lib/src/overlay/focus_overlay.dart (1 hint)
  • lib/src/preference/list_preference.dart (1 hint)
  • lib/src/preference/multi_select_list_preference.dart (1 hint)
  • lib/src/preference/text_field_preference.dart (1 hint)
  • lib/src/text/adept_text_field.dart (1 hint)
  • lib/src/text/date_text_field.dart (1 hint)
  • lib/src/drawer/drawers.dart (Run flutter format to format lib/src/drawer/drawers.dart.)
  • lib/src/drop_down/auto_complete_drop_down_form_field.dart (Run flutter format to format lib/src/drop_down/auto_complete_drop_down_form_field.dart.)
  • lib/src/preference/preferences.dart (Run flutter format to format lib/src/preference/preferences.dart.)
  • lib/src/preference/switch_preference.dart (Run flutter format to format lib/src/preference/switch_preference.dart.)
  • lib/src/reactive_refresh_indicator.dart (Run flutter format to format lib/src/reactive_refresh_indicator.dart.)
  • lib/src/text/badge.dart (Run flutter format to format lib/src/text/badge.dart.)
  • lib/src/text/nokeyboard_editable_text.dart (Run flutter format to format lib/src/text/nokeyboard_editable_text.dart.)
  • lib/src/text/texts.dart (Run flutter format to format lib/src/text/texts.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (flutter_html, mdi).

Homepage URL isn't helpful. (-10 points)

Update the homepage field from pubspec.yaml: link to a website about the package or use the source repository URL.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and adeptviews.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
adeptutils ^1.1.6+21 1.1.6+21
community_material_icon ^3.5.95 3.5.95
flutter 0.0.0
flutter_html ^0.11.1 0.11.1 1.0.0
font_awesome_flutter ^8.7.0 8.8.1
mdi ^1.0.1 1.0.1 3.0.0
Transitive dependencies
charcode 1.1.3
collection 1.14.12
csslib 0.16.1
date_format 1.0.8
device_info 0.4.2+4
flutter_web_plugins 0.0.0
fluttertoast 3.1.3 4.0.1
html 0.14.0+3
http 0.12.1
http_parser 3.1.4
intl 0.16.1
json_annotation 3.0.1
meta 1.1.8
modal_progress_hud 0.1.3
package_info 0.4.1
path 1.7.0
pedantic 1.9.0
platform_detect 1.4.0
plugin_platform_interface 1.0.2
pub_semver 1.4.4
shared_preferences 0.5.7+3
shared_preferences_macos 0.0.1+10
shared_preferences_platform_interface 1.0.4
shared_preferences_web 0.1.2+7
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
url_launcher 5.4.10
url_launcher_macos 0.0.1+7
url_launcher_platform_interface 1.0.7
url_launcher_web 0.1.1+6
validators 2.0.0+1
vector_math 2.0.8
Dev dependencies
flutter_test