action_sheet 1.0.4 copy "action_sheet: ^1.0.4" to clipboard
action_sheet: ^1.0.4 copied to clipboard

A material bottom sheet with clickable actions as seen in Google Drive.

7
likes
130/ 140
pub points
57%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

3 out of 4 API elements (75.0 %) have documentation comments.

Some symbols that are missing documentation: action_sheet.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: Use 'isEmpty' instead of 'length' to test whether the collection is empty.

lib/action_sheet.dart:248:9

    ╷
248 │     if (actions.length == 0) {
    │         ^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/action_sheet.dart

INFO: Statements in an if should be enclosed in a block.

lib/action_sheet.dart:408:7

    ╷
408 │ ┌       rowList.add(SizedBox(
409 │ │         height: rowGap,
410 │ └       ));
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/action_sheet.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Flutter 3.19.0, Dart 3.3.0.

Check the analysis log for details.

7
likes
130
pub points
57%
popularity

Publisher

verified publisherfelixboehme.dev

A material bottom sheet with clickable actions as seen in Google Drive.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on action_sheet