aamarpay 0.0.7
aamarpay: ^0.0.7 copied to clipboard

Flutter Android iOS

aamarPay is an online payment gateway service for Bangladesh.

11
likes
80 / 110
pub points
41 %
popularity

We analyzed this package on Mar 3, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 28 API elements (3.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:aamarpay/aamarpay.dart that imports:
  • package:aamarpay/src/aamarpaydata.dart that imports:
  • package:aamarpay/src/web_view.dart that imports:
  • package:flutter_inappwebview/flutter_inappwebview.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/aamarpaydata.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_inappwebview^4.0.0+44.0.0+45.0.5+3
http^0.12.20.12.20.13.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
http_parser-3.1.44.0.0
meta-1.3.01.3.0
mime-0.9.71.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.1
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.0+4` on flutter_inappwebview does not support the stable version `5.0.5`, that was published 2 days ago.

When flutter_inappwebview is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_inappwebview to update the constraint.

The constraint `^0.12.2` on http does not support the stable version `0.13.0`, that was published 26 days ago.

When http is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.2, Flutter 1.26.0-17.8.pre, Dart 2.12.0 (build 2.12.0-259.16.beta).

11
likes
80
pub points
41%
popularity

aamarPay is an online payment gateway service for Bangladesh.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

masumbillahsanjid@gmail.com

License

unknown (LICENSE)

Dependencies

flutter, flutter_inappwebview, http

More

Packages that depend on aamarpay