_fe_analyzer_shared 13.0.0
_fe_analyzer_shared: ^13.0.0

Dart native
Flutter Android iOS

Logic that is shared between the front_end and analyzer packages.

0
likes
75 / 110
pub points
99 %
popularity

We analyzed this package on Nov 26, 2020, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 0 API elements (100.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:_fe_analyzer_shared/src/parser/parser_main.dart that imports:
  • package:_fe_analyzer_shared/src/scanner/io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 2142 issues. Showing the first 2:

INFO: Prefer using /// for doc comments.

lib/src/base/errors.dart:12:3

   ╷
12 │ ┌   /**
13 │ │    * The name of the error code.
14 │ └    */
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/base/errors.dart

INFO: Prefer using /// for doc comments.

lib/src/base/errors.dart:21:3

   ╷
21 │ ┌   /**
22 │ │    * Return `true` if diagnostics with this code have documentation for them
23 │ │    * that has been published.
24 │ └    */
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/base/errors.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
meta^1.0.21.2.41.2.4

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
75
pub points
99%
popularity

Publisher

dart.dev

Logic that is shared between the front_end and analyzer packages.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

meta

More

Packages that depend on _fe_analyzer_shared