zomato_dart 1.0.3
zomato_dart: ^1.0.3 copied to clipboard

A wrapper for the Zomato API that exposes dart objects. The various endpoints of the API can be accessed through convenience methods that return a Future.

0
likes
80 / 130
pub points
0 %
popularity

We analyzed this package on Jul 28, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 66 out of 408 API elements (16.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

lib/models/category.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/models/city.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.0+40.12.20.13.3
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
http_parser-3.1.44.0.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0+4` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=1.8.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Dart 2.13.4.

0
likes
80
pub points
0%
popularity

A wrapper for the Zomato API that exposes dart objects. The various endpoints of the API can be accessed through convenience methods that return a Future.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

http

More

Packages that depend on zomato_dart