zflutter 0.0.1+2
zflutter: ^0.0.1+2 copied to clipboard

Flutter Android iOS Linux macOS web Windows

A round, flat and designer-friendly pseudo-3D engine for Flutter

21
likes
90 / 110
pub points
66 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 58 out of 378 API elements (15.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: A value for optional parameter 'path' isn't ever given.

lib/src/widgets/figures/hemisphere.dart:56:42

   ╷
56 │       {this.diameter, List<ZPathCommand> path, double stroke = 1, Color color})
   │                                          ^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/widgets/figures/hemisphere.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
quiver^2.1.32.1.53.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
matcher-0.12.100.12.10
meta-1.3.01.3.0
path-1.8.01.8.0
sky_engine-0.0.990.0.99
stack_trace-1.10.01.10.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.1.3` on quiver does not support the stable version `3.0.0`, that was published 14 days ago.

When quiver is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions quiver to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.

21
likes
90
pub points
66%
popularity

Publisher

z.flutter.gallery

A round, flat and designer-friendly pseudo-3D engine for Flutter

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, quiver

More

Packages that depend on zflutter