zendesk_classic 1.0.2 copy "zendesk_classic: ^1.0.2" to clipboard
zendesk_classic: ^1.0.2 copied to clipboard

A Zendesk plugin is a software extension that integrates with the Zendesk customer support platform, designed to enhance and customize its functionality.

3
likes
150/ 160
pub points
62%
popularity

We analyzed this package 4 days ago, and awarded it 150 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://avinashgotluru.me was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

8 out of 13 API elements (61.5 %) have documentation comments.

Some symbols that are missing documentation: zendesk_classic, zendesk_classic_method_channel, zendesk_classic_method_channel.MethodChannelZendeskClassic.optionalMethodChannel, zendesk_classic_platform_interface, zendesk_classic_platform_interface.ZendeskClassicPlatform.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:zendesk_classic/zendesk_classic.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:zendesk_classic/zendesk_classic.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:zendesk_classic/zendesk_classic.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:zendesk_classic/zendesk_classic.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

3
likes
150
pub points
62%
popularity

Publisher

verified publisheravinashgotluru.me

A Zendesk plugin is a software extension that integrates with the Zendesk customer support platform, designed to enhance and customize its functionality.

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, plugin_platform_interface

More

Packages that depend on zendesk_classic