zefyr_rtl 1.0.0-dev.2.0-patch7 icon indicating copy to clipboard operation
zefyr_rtl: ^1.0.0-dev.2.0-patch7 copied to clipboard

Clean, minimalistic and collaboration-ready rich text editor for Flutter.

0
likes
90/ 130
pub points
0%
popularity

We analyzed this package 34 hours ago, and awarded it 90 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 204 out of 317 API elements (64.4 %) have documentation comments.
icon indicating section status
Support multiple platforms
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

lib/src/widgets/editable_text_block.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/widgets/editable_text_line.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
characters^1.0.01.2.01.2.0
collection^1.14.61.15.01.15.0
flutterflutter0.0.00.0.0
meta^1.1.01.7.01.7.0
notus^1.0.0-dev1.0.0-dev.4.01.0.0-rc.2
quill_delta^2.0.02.0.02.0.0
quiver_hashcode^2.0.02.0.03.0.0+1
url_launcher^5.0.05.7.106.0.18
Transitive dependencies
PackageConstraintCompatibleLatest
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.4
plugin_platform_interface-1.0.32.1.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
url_launcher_linux-0.0.1+42.0.2
url_launcher_macos-0.0.1+92.0.2
url_launcher_platform_interface-1.0.92.0.5
url_launcher_web-0.1.5+32.0.6
url_launcher_windows-0.0.1+32.0.2
vector_math-2.1.12.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0` on quiver_hashcode does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions quiver_hashcode to update the constraint.

The constraint `^5.0.0` on url_launcher does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions url_launcher to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.10.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.8.1, Dart 2.15.1.

0
likes
90
pub points
0%
popularity

Clean, minimalistic and collaboration-ready rich text editor for Flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

characters, collection, flutter, meta, notus, quill_delta, quiver_hashcode, url_launcher

More

Packages that depend on zefyr_rtl