zefyr_nitro 0.10.2
zefyr_nitro: ^0.10.2 copied to clipboard

It's a fork from https://github.com/memspace/zefyr

3
likes
80/ 130
pub points
3%
popularity

We analyzed this package on Oct 19, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/mhbdev/zefyr was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 200 out of 352 API elements (56.8 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
clipboard_manager^0.0.40.0.40.0.4
collection^1.14.61.15.01.15.0
flutterflutter0.0.00.0.0
meta^1.1.01.7.01.7.0
notus^0.1.00.1.50.1.5
quill_delta^1.0.01.1.32.0.0
quiver_hashcode^2.0.02.0.03.0.0+1
url_launcher^5.0.05.7.106.0.12
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
plugin_platform_interface-1.0.32.0.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
url_launcher_linux-0.0.1+42.0.2
url_launcher_macos-0.0.1+92.0.2
url_launcher_platform_interface-1.0.92.0.4
url_launcher_web-0.1.5+32.0.4
url_launcher_windows-0.0.1+32.0.2
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.0.0` on quill_delta does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions quill_delta to update the constraint.

The constraint `^2.0.0` on quiver_hashcode does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions quiver_hashcode to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.2 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

3
likes
80
pub points
3%
popularity

Publisher

packs.apexteam.net

It's a fork from https://github.com/memspace/zefyr

Repository (missing)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

clipboard_manager, collection, flutter, meta, notus, quill_delta, quiver_hashcode, url_launcher

More

Packages that depend on zefyr_nitro