zefyr 0.12.0
zefyr: ^0.12.0 copied to clipboard

Clean, minimalistic and collaboration-ready rich text editor for Flutter.

276
likes
90 / 130
pub points
92 %
popularity

We analyzed this package on Jun 11, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 215 out of 365 API elements (58.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:zefyr/zefyr.dart that imports:
  • package:zefyr/src/widgets/view.dart that imports:
  • package:zefyr/src/widgets/scope.dart that imports:
  • package:zefyr/src/widgets/editor.dart that imports:
  • package:zefyr/src/widgets/editable_text.dart that imports:
  • package:zefyr/src/widgets/selection.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.14.61.15.01.15.0
flutterflutter0.0.00.0.0
meta^1.1.01.3.01.4.0
notus^0.1.00.1.50.1.5
quill_delta^1.0.01.1.32.0.0
quiver_hashcode^2.0.02.0.03.0.0+1
url_launcher^5.0.05.7.106.0.6
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
plugin_platform_interface-1.0.32.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
url_launcher_linux-0.0.1+42.0.0
url_launcher_macos-0.0.1+92.0.0
url_launcher_platform_interface-1.0.92.0.3
url_launcher_web-0.1.5+32.0.1
url_launcher_windows-0.0.1+32.0.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.0.0` on quill_delta does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions quill_delta to update the constraint.

The constraint `^2.0.0` on quiver_hashcode does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions quiver_hashcode to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.2 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.17.1, Flutter 2.2.1, Dart 2.13.1.

276
likes
90
pub points
92%
popularity

Publisher

Unknown

Clean, minimalistic and collaboration-ready rich text editor for Flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

collection, flutter, meta, notus, quill_delta, quiver_hashcode, url_launcher

More

Packages that depend on zefyr