yoyo_player 0.1.0 icon indicating copy to clipboard operation
yoyo_player: ^0.1.0 copied to clipboard

yoyo_player is a video player that allows you to select HLS video streaming by selecting the quality

115
likes
100/ 140
pub points
85%
popularity

We analyzed this package 5 days ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 24 API elements (41.7 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform Windows.

Because:

  • package:yoyo_player/yoyo_player.dart that imports:
  • package:yoyo_player/src/video.dart that imports:
  • package:yoyo_player/src/widget/widget_bottombar.dart that imports:
  • package:yoyo_player/src/responses/play_response.dart that imports:
  • package:video_player/video_player.dart that declares support for platforms: Android, iOS, Web.

Package does not support platform Linux.

Because:

  • package:yoyo_player/yoyo_player.dart that imports:
  • package:yoyo_player/src/video.dart that imports:
  • package:yoyo_player/src/widget/widget_bottombar.dart that imports:
  • package:yoyo_player/src/responses/play_response.dart that imports:
  • package:video_player/video_player.dart that declares support for platforms: Android, iOS, Web.

Package does not support platform macOS.

Because:

  • package:yoyo_player/yoyo_player.dart that imports:
  • package:yoyo_player/src/video.dart that imports:
  • package:yoyo_player/src/widget/widget_bottombar.dart that imports:
  • package:yoyo_player/src/responses/play_response.dart that imports:
  • package:video_player/video_player.dart that declares support for platforms: Android, iOS, Web.

Package does not support platform Web.

Because:

  • package:yoyo_player/yoyo_player.dart that imports:
  • package:yoyo_player/src/video.dart that imports:
  • package:screen/screen.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform Android.

Because:

  • package:yoyo_player/yoyo_player.dart that imports:
  • package:yoyo_player/src/video.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.

Package does not support platform iOS.

Because:

  • package:yoyo_player/yoyo_player.dart that imports:
  • package:yoyo_player/src/video.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: 'List.List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/video.dart:112:25

    ╷
112 │   List<M3U8pass> yoyo = List();
    │                         ^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/video.dart

INFO: 'List.List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/video.dart:114:27

    ╷
114 │   List<AUDIO> audioList = List();
    │                           ^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/video.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
http^0.12.20.12.20.13.5
orientation^1.2.01.3.01.3.0
path_provider^1.6.211.6.282.0.11
screen^0.0.50.0.50.0.5
video_player^0.11.1+20.11.1+52.4.8
video_player_web_hls^0.1.80.1.81.0.0+1
wakelock^0.2.0+10.2.1+10.6.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
charcode-1.3.11.3.1
collection-1.16.01.17.0
csslib-0.16.20.17.2
ffi-1.2.12.0.1
file-6.1.46.1.4
flutter_web_plugins-0.0.00.0.0
html-0.14.0+40.15.1
http_parser-3.1.44.0.2
import_js_library-1.0.21.0.2
js-0.6.40.6.5
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
path-1.8.21.8.2
path_provider_linux-0.0.1+22.1.7
path_provider_macos-0.0.4+82.0.6
path_provider_platform_interface-1.0.42.0.5
path_provider_windows-0.0.52.1.3
pedantic-1.11.11.11.1
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.1.3
process-4.2.44.2.4
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.4
video_player_platform_interface-2.2.06.0.0
video_player_web-0.1.4+12.0.12
wakelock_platform_interface-0.1.0+10.3.0
wakelock_web-0.1.0+30.4.0
win32-2.6.13.1.2
xdg_directories-0.1.20.2.0+2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint ^0.12.2 on http does not support the stable version 0.13.0.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint ^1.6.21 on path_provider does not support the stable version 2.0.0.

Try running dart pub upgrade --major-versions path_provider to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.7.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

115
likes
100
pub points
85%
popularity

Publisher

verified publisher iconkohtut.dev

yoyo_player is a video player that allows you to select HLS video streaming by selecting the quality

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter, http, orientation, path_provider, screen, video_player, video_player_web_hls, wakelock

More

Packages that depend on yoyo_player