youtube_data_v3 0.0.1+1

Flutter Android iOS

A youtubeV3 package which contains functions to access Youtube Data API V3 via the API key.

3
likes
70 / 110
pub points
51 %
popularity

We analyzed this package on Sep 22, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 52 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:youtube_data_v3/youtube_data_v3.dart that imports:
  • package:googleapis_auth/auth_io.dart that imports:
  • package:googleapis_auth/src/oauth2_flows/metadata_server.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/youtube_channel.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/youtube_data_v3.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
googleapis^0.53.00.53.00.55.0
googleapis_auth^0.2.70.2.120.2.12
http^0.12.0+20.12.20.12.2
Transitive dependencies
PackageConstraintCompatibleLatest
_discoveryapis_commons-0.1.90.2.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
http_parser-3.1.43.1.4
meta-1.2.31.2.3
path-1.7.01.7.0
pedantic-1.9.21.9.2
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.53.0` on googleapis does not support the latest published version `0.55.0`

pubspec.yaml:13:15

   ╷
13 │   googleapis: ^0.53.0
   │               ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

3
likes
70
pub points
51%
popularity

A youtubeV3 package which contains functions to access Youtube Data API V3 via the API key.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

cvadityagithub@gmail.com

License

BSD (LICENSE)

Dependencies

googleapis, googleapis_auth, http

More

Packages that depend on youtube_data_v3