yabwe 0.0.2

Wrap of MediumEditor

Basic usage #

<head>
    ...
    <script src="//cdn.jsdelivr.net/npm/medium-editor@latest/dist/js/medium-editor.min.js"></script>
    <link rel="stylesheet" href="//cdn.jsdelivr.net/npm/medium-editor@latest/dist/css/medium-editor.min.css" type="text/css" media="screen" charset="utf-8">
    ...
</head>

<body>
    ...
    <div class="editable"></div>
    ...
</body>
final mediumEditor = new MediumEditor(element.querySelector('.editable'),
    options: new MediumEditorOptions(
        placeholder:
            new PlaceHolderOptions(text: 'Your note', hideOnClick: true)));

To set the content of the editor use setContent like that

mediumEditor.setContent("Edit me!");

And to get the content of the editor use getContent

final content = mediumEditor.getContent();

Changelog #

0.0.2 #

  • Dart 2 stable

0.0.1 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  yabwe: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:yabwe/yabwe.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
36
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
64
Learn more about scoring.

We analyzed this package on Jul 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: web

Primary library: package:yabwe/yabwe.dart with components: html, js.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and yabwe.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <3.0.0
dart_browser_loader ^0.0.4 0.0.5
js ^0.6.1 0.6.1+1
Dev dependencies
test ^1.3.0

Admin