xdbgen 1.0.7
xdbgen: ^1.0.7 copied to clipboard

A starting point for Dart libraries or applications.

0
likes
95/ 130
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 95 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.
The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:11:49

   ╷
11 │ <p>Please file feature requests and bugs at the <a href="http://example.com/issues/replaceme">issue tracker</a>.</p>
   │                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/xdbgen_example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 20 API elements (5.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:xdbgen/xdbgen.dart that imports:
  • package:xdbgen/src/xdbgen_base.dart that imports:
  • package:xdatabase/xdatabase.dart that imports:
  • package:xdatabase/src/xdatabase_base.dart that imports:
  • package:xdatabase/src/connection_pool.dart that imports:
  • package:postgres/postgres.dart that imports:
  • package:postgres/src/substituter.dart that imports:
  • package:postgres/src/query.dart that imports:
  • package:postgres/src/execution_context.dart that imports:
  • package:postgres/src/connection.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
pathany1.8.01.8.0
xdatabaseany1.0.91.0.9
Transitive dependencies
PackageConstraintCompatibleLatest
buffer-1.1.11.1.1
collection-1.15.01.15.0
crypto-3.0.13.0.1
postgres-2.4.32.4.3
sasl_scram-0.1.00.1.0
saslprep-1.0.21.0.2
typed_data-1.3.01.3.0
unorm_dart-0.2.00.2.0
uuid-3.0.53.0.5

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.14.4.

0
likes
95
pub points
0%
popularity

A starting point for Dart libraries or applications.

Documentation

API reference

License

GPL-3.0 (LICENSE)

Dependencies

path, xdatabase

More

Packages that depend on xdbgen