xcodeproj 0.2.3 copy "xcodeproj: ^0.2.3" to clipboard
xcodeproj: ^0.2.3 copied to clipboard

A library for reading and modifying XCode projects.

3
likes
130/ 160
pub points
40%
popularity

We analyzed this package 4 days ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected licenses: MIT, BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

135 out of 282 API elements (47.9 %) have documentation comments.

Some symbols that are missing documentation: xcodeproj.AdditionalOptions, xcodeproj.AnalyzeAction, xcodeproj.AnalyzeAction.AnalyzeAction, xcodeproj.ArchiveAction, xcodeproj.ArchiveAction.ArchiveAction.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:xcodeproj/xcodeproj.dart that imports:
  • package:xcodeproj/src/plist/plist.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 21 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/src/pbx/build_configuration.dart:1:1

  ╷
1 │ part of pbx;
  │ ^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/pbx/build_configuration.dart

INFO: The part-of directive uses a library name.

lib/src/pbx/build_file.dart:1:1

  ╷
1 │ part of pbx;
  │ ^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/pbx/build_file.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.19.0 1.19.0
crypto ^3.0.0 3.0.3 3.0.3
path ^1.8.0 1.9.0 1.9.0
petitparser ^5.0.0 5.4.0 6.0.2
quiver ^3.0.0 3.2.1 3.2.1
snapshot ^0.2.0 0.2.6 0.2.6
xml ^6.0.0 6.3.0 6.5.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
clock - 1.1.1 1.1.1
intl - 0.17.0 0.19.0
matcher - 0.12.16+1 0.12.16+1
meta - 1.15.0 1.15.0
rxdart - 0.27.7 0.28.0
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.2 0.7.2
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.0.0` on petitparser does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions petitparser to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.

3
likes
130
pub points
40%
popularity

Publisher

verified publisherappsup.be

A library for reading and modifying XCode projects.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT, BSD-3-Clause (LICENSE)

Dependencies

collection, crypto, path, petitparser, quiver, snapshot, xml

More

Packages that depend on xcodeproj