x_icon 0.0.5 copy "x_icon: ^0.0.5" to clipboard
x_icon: ^0.0.5 copied to clipboard

part of flutter remote-ui project. dynamic and remote icon loader for flutter

3
likes
90/ 160
pub points
49%
popularity

We analyzed this package 5 days ago, and awarded it 90 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/softmarshmallow/remote-ui/tree/master/flutter/packages/x_icon was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

16 out of 33 API elements (48.5 %) have documentation comments.

Some symbols that are missing documentation: x_icon, x_icon.IconMapper, x_icon.IconMapper.IconMapper, x_icon.IconMapper.namespace, x_icon.XIcon.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 18 issues. Showing the first 2:

ERROR: The getter 'caption' isn't defined for the type 'TextTheme'.

lib/src/icon.dart:54:12

   ╷
54 │           .caption!
   │            ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/icon.dart

ERROR: The getter 'errorColor' isn't defined for the type 'ThemeData'.

lib/src/icon.dart:55:46

   ╷
55 │           .copyWith(color: Theme.of(context).errorColor),
   │                                              ^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/icon.dart

failed
Support up-to-date dependencies
20 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
json_annotation ^4.0.1 4.9.0 4.9.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 5 errors:

  • UNDEFINED_GETTER - lib/src/icon.dart:54:12 - The getter 'caption' isn't defined for the type 'TextTheme'.
  • UNDEFINED_GETTER - lib/src/icon.dart:55:46 - The getter 'errorColor' isn't defined for the type 'ThemeData'.
  • CONST_INITIALIZED_WITH_NON_CONSTANT_VALUE - lib/src/material_icons_mapping.dart:677:25 - Const variables must be initialized with a constant value.

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

3
likes
90
pub points
49%
popularity

Publisher

verified publishergrida.co

part of flutter remote-ui project. dynamic and remote icon loader for flutter

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (license)

Dependencies

flutter, json_annotation

More

Packages that depend on x_icon