wordpress_api 0.1.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 82

WordPress API client for Dart (Flutter)

Description #

A WordPress API client for flutter with support for WooCommerce and custom namespaces.

Features #

  • Retrieve data from any endpoint.
  • Retrieve data from any namespace.

Installation #

In the dependencies: section of your pubspec.yaml, add the following line:

wordpress_api: <latest_version>

Usage #

  • Import the package
import 'package:wordpress_api/wordpress_api';
  • Initialize WPAPI
  WordPressAPI api = WordPressAPI('site.com');
  • Retrieve data from a custom endpoint
  void main() async {
    final wp = WordPressAPI('260blog.com');
    final posts = (await wp.getAsync('posts'))['data'];
    for (final post in posts) {
  • Retrieve WP users
  void main() async {
    final wp = WordPressAPI('260blog.com');
    final users = (await wp.getUsers())['data'];
    for (final user in users) {

To Do #

  • Add authentication function
  • Add postAsync function

Contributions are welcome, report any issues here


  • Removed all flutter references because the package also works standalone for dart. Thanks jld3103
  • Added Wordpress Standard endpoints as requested in issue #3. These include getPosts(), getCategories(), getTags(), getComments(), and getUsers() functions.


  • Minor fixes


  • Added endpoint query handler


  • Added getAsyc exception


  • Fixed the error in JSON endpoint retrieval


  • Changed getAsync return raw json body
  • Changed example code url


  • Changed getAsync return data to a map.


  • Updated example and readme


  • Added an example


  • Updated documentation


  • Initial release.


wordpress api example #

Demonstrates how the worpress api client can be used

Getting Started #

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  wordpress_api: ^0.1.3

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:wordpress_api/wordpress_api.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Nov 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:wordpress_api/wordpress_api.dart.

Health suggestions

Format lib/wordpress_api.dart.

Run dartfmt to format lib/wordpress_api.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
http ^0.12.0+2 0.12.0+2
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.12
http_parser 3.1.3
meta 1.1.8
path 1.6.4
pedantic 1.8.0+1
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6