with_controller 1.0.2 icon indicating copy to clipboard operation
with_controller: ^1.0.2 copied to clipboard

A package provinding the WithController widget. It is a convenience widget for reducing MobX boilerplate burden when you need to initialize a store, create reactions and dispose.

4
likes
110/ 140
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 110 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 26 API elements (38.5 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
mobx^1.0.21.2.1+42.1.3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.16.01.17.0
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^1.0.2 on mobx does not support the stable version 2.0.0.

Try running dart pub upgrade --major-versions mobx to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.1.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

4
likes
110
pub points
0%
popularity

Publisher

verified publisher iconsavioserra.dev

A package provinding the WithController widget. It is a convenience widget for reducing MobX boilerplate burden when you need to initialize a store, create reactions and dispose.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter, mobx

More

Packages that depend on with_controller