wing 0.0.4
wing: ^0.0.4 copied to clipboard

A backend framework with automated REST generation

0
likes
45/ 130
pub points
0%
popularity

We analyzed this package 23 hours ago, and awarded it 45 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 14 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:wing/wing.dart that imports:
  • package:wing/src/Database_Manager.dart that imports:
  • package:mongo_dart/mongo_dart.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/src/Database_Manager.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/routing.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
mongo_dart^0.3.50.3.60.7.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
bson-0.3.41.0.4
characters-1.2.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
fixnum-0.10.111.0.0
logging-0.11.41.0.2
meta-1.7.01.7.0
mongo_dart_query-0.3.21.0.2
more-2.8.03.3.0
path-1.8.01.8.0
pool-1.5.01.5.0
rational-0.3.82.0.0
stack_trace-1.10.01.10.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.5

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.3.5` on mongo_dart does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions mongo_dart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

0
likes
45
pub points
0%
popularity

A backend framework with automated REST generation

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

mongo_dart

More

Packages that depend on wing