widget_kit_plugin 0.1.1 copy "widget_kit_plugin: ^0.1.1" to clipboard
widget_kit_plugin: ^0.1.1 copied to clipboard

PlatformiOSmacOS

A library for interfacing with a small subset of the WidgetKit API.

6
likes
130/ 140
pub points
81%
popularity

We analyzed this package 26 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

21 out of 45 API elements (46.7 %) have documentation comments.

Some symbols that are missing documentation: user_defaults, user_defaults, user_defaults.UserDefaultsAPI, user_defaults.UserDefaultsAPI.codec, user_defaults.UserDefaultsAPI.contains.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ iOS
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:widget_kit_plugin/widget_kit_plugin.dart that declares support for platforms: iOS, macOS.
Package does not support platform `Windows`.

Because:

  • package:widget_kit_plugin/widget_kit_plugin.dart that declares support for platforms: iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:widget_kit_plugin/widget_kit_plugin.dart that declares support for platforms: iOS, macOS.
Package does not support platform `Web`.

Because:

  • package:widget_kit_plugin/widget_kit_plugin.dart that declares support for platforms: iOS, macOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/api/user_defaults.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/api/widget_kit.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

6
likes
130
pub points
81%
popularity
screenshot

Publisher

verified publishergameflow.tv

A library for interfacing with a small subset of the WidgetKit API.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on widget_kit_plugin