whatsapp_stickers 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 54

whatsapp_stickers #

A Flutter plugin for adding stickers to WhatsApp.

Notes #

Currently iOS is the only supported platform. Android will be added soon.

Usage #

To use this plugin, add whatsapp_stickers as a dependency in your pubspec.yaml file.

Example #

Put your stickers in any folder, for example, assets. Do not forget to add this folder to pubspec.yaml.

var stickerPack = WhatsappStickers(
    "Cuppy Flutter WhatsApp Stickers",
    "John Doe",

  ..addSticker("assets/01_Cuppy_smile.webp", ["☕","🙂"])
  ..addSticker("assets/02_Cuppy_lol.webp", ["😄","😀"])
  ..addSticker("assets/03_Cuppy_rofl.webp", ["😆","😂"])
  ..addSticker("assets/04_Cuppy_sad.webp", ["😃", "😍"])
  ..addSticker("assets/05_Cuppy_cry.webp", ["😭","💧"])
  ..addSticker("assets/06_Cuppy_love.webp", ["😍","♥"])
  ..addSticker("assets/07_Cuppy_hate.webp", ["💔","👎"])
  ..addSticker("assets/08_Cuppy_lovewithmug.webp", ["😍","💑"])
  ..addSticker("assets/09_Cuppy_lovewithcookie.webp", ["😘","🍪"])
  ..addSticker("assets/10_Cuppy_hmm.webp", ["🤔","😐"])
  ..addSticker("assets/11_Cuppy_upset.webp", ["😱","😵"])
  ..addSticker("assets/12_Cuppy_angry.webp", ["😡","😠"])
  ..addSticker("assets/13_Cuppy_curious.webp", ["❓","🤔"])
  ..addSticker("assets/14_Cuppy_weird.webp", ["🌈","😜"])
  ..addSticker("assets/15_Cuppy_bluescreen.webp", ["💻","😩"])
  ..addSticker("assets/16_Cuppy_angry.webp", ["😡","😤"])
  ..addSticker("assets/17_Cuppy_tired.webp", ["😩","😨"])
  ..addSticker("assets/18_Cuppy_workhard.webp", ["😔", "😨"])
  ..addSticker("assets/19_Cuppy_shine.webp", ["🎉","✨"])
  ..addSticker("assets/20_Cuppy_disgusting.webp", ["🤮","👎"])
  ..addSticker("assets/21_Cuppy_hi.webp", ["🖐","🙋"])
  ..addSticker("assets/22_Cuppy_bye.webp", ["🖐","👋"]);

try {
  await stickerPack.sendToWhatsApp();
} on WhatsappStickersException catch (e) {

0.0.1 #

  • Added initial support of iOS


whatsapp_stickers_example #

Demonstrates how to use the whatsapp_stickers plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  whatsapp_stickers: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:whatsapp_stickers/whatsapp_stickers.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Nov 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/exceptions.dart.

Run flutter format to format lib/exceptions.dart.

Format lib/whatsapp_stickers.dart.

Run flutter format to format lib/whatsapp_stickers.dart.

Format lib/whatsapp_stickers.pb.dart.

Run flutter format to format lib/whatsapp_stickers.pb.dart.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/whatsapp_stickers.pbenum.dart (Run flutter format to format lib/whatsapp_stickers.pbenum.dart.)
  • lib/whatsapp_stickers.pbjson.dart (Run flutter format to format lib/whatsapp_stickers.pbjson.dart.)
  • lib/whatsapp_stickers.pbserver.dart (Run flutter format to format lib/whatsapp_stickers.pbserver.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (protobuf).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
protobuf ^0.13.11 0.13.16+1 1.0.1
Transitive dependencies
collection 1.14.11 1.14.12
fixnum 0.10.11
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies