weight_slider 1.0.1

  • Readme
  • Changelog
  • Installing
  • new44

Weight Slider Widget for Flutter

Pub Version License: MIT

✨ Demo #

weight slider

🚀 Usage #

class _MyHomePageState extends State<MyHomePage> {
  int weight = 70;

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text(widget.title),
      ),
      body: Center(
        child: WeightSlider(
            weight: weight,
            minWeight: 40,
            maxWeight: 120,
            onChanged: (val) => setState(() => weight = val),
          ),
        ),
    );
  }
}

📝 License #

This project is MIT licensed.

Changelog #

1.0.1 #

  • Ran flutter format

1.0.0 #

  • Created weight slider widget

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  weight_slider: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:weight_slider/weight_slider.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
69
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Jan 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Fix lib/src/weight_slider_interal.dart. (-1 points)

Analysis of lib/src/weight_slider_interal.dart reported 2 hints:

line 86 col 35: The member 'activity' can only be used within instance members of subclasses of 'package:flutter/src/widgets/scroll_position.dart'.

line 86 col 35: The member 'activity' can only be used within 'package:flutter/src/widgets/scroll_position.dart' or a test.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (flutter_svg).

The package description is too short. (-11 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and weight_slider.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
flutter_svg ^0.15.0 0.15.0 0.16.0
Transitive dependencies
charcode 1.1.2
collection 1.14.11 1.14.12
convert 2.1.1
meta 1.1.8
path_drawing 0.4.1
path_parsing 0.1.4
petitparser 3.0.0
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
xml 3.7.0