web_socket_io 0.0.4 icon indicating copy to clipboard operation
web_socket_io: ^0.0.4 copied to clipboard

WebSocket implement based on dart。Used to canary client sdk.My purpose is to learn dart syntax and development process。

1
likes
115/ 140
pub points
40%
popularity

We analyzed this package 3 days ago, and awarded it 115 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
25 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 148 API elements (4.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:web_socket_io/web_socket_io.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:web_socket_io/web_socket_io.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:web_socket_io/web_socket_io.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:web_socket_io/web_socket_io.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: Unnecessary braces in a string interpolation.

lib/web_socket_client.dart:74:16

   ╷
74 │     h.add('GET ${url} HTTP/1.1');
   │                ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/web_socket_client.dart

INFO: Unused import: 'dart:ffi'.

lib/web_socket_provider.dart:3:8

  ╷
3 │ import 'dart:ffi';
  │        ^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/web_socket_provider.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crypto^3.0.13.0.23.0.2
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.17.01.17.1
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
sky_engine-0.0.990.0.99
typed_data-1.3.11.3.1
vector_math-2.1.42.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

1
likes
115
pub points
40%
popularity

Publisher

verified publisher iconpub.wildlotus.shop

WebSocket implement based on dart。Used to canary client sdk.My purpose is to learn dart syntax and development process。

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

crypto, flutter

More

Packages that depend on web_socket_io