web3dart_builders 0.1.0 copy "web3dart_builders: ^0.1.0" to clipboard
web3dart_builders: ^0.1.0 copied to clipboard

Extension of the web3dart package that includes the dart contract generator from abi.

Description #

Helper package for the (xclud/web3dart) library responsible for generating dart classes from abi contracts This project is part of this repository simolus3/web3dart.

Requirements #

web3dart 2.5.1

Installation #

  1. Add to pubspec.yaml in your project: dev_dependencies: web3dart_builders: ^0.1.0 or call
dart pub add build_runner --dev
dart pub add web3dart_builders --dev

Usage #

pub run build_runner build

or

pub run build_runner watch

Test #

dart test
4
likes
110
pub points
66%
popularity

Publisher

unverified uploader

Extension of the web3dart package that includes the dart contract generator from abi.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

build, built_collection, code_builder, dart_style, path, web3dart

More

Packages that depend on web3dart_builders