web3_contract_generator 0.1.4 icon indicating copy to clipboard operation
web3_contract_generator: ^0.1.4 copied to clipboard

Generates dart classes corresponding to ABIs of Solidity smart contracts

8
likes
90/ 140
pub points
0%
popularity

We analyzed this package 17 hours ago, and awarded it 90 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 30 API elements (36.7 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:web3_contract_generator/web3_contract_generator.dart that imports:
  • package:web3_contract_generator/generator.dart that imports:
  • package:web3_contract_generator/helpers.dart that imports:
  • package:web3dart/web3dart.dart that imports:
  • package:isolate/isolate.dart that imports:
  • package:isolate/registry.dart that imports:
  • package:isolate/ports.dart that imports:
  • dart:isolate
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: The value of the local variable 'late_keyword_padded' isn't used.

lib/generator.dart:56:7

   ╷
56 │   var late_keyword_padded = nonNullableEnabled ? 'late ' : ' ';
   │       ^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/generator.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/generator.dart:56:7

   ╷
56 │   var late_keyword_padded = nonNullableEnabled ? 'late ' : ' ';
   │       ^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/generator.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
build^1.5.01.6.22.3.1
dart_style^1.3.71.3.122.2.4
dartz^0.9.20.9.20.10.1
logging^0.11.40.11.41.1.0
meta^1.2.31.8.01.8.0
path^1.7.01.8.21.8.2
web3dart^1.2.31.2.32.5.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.050.0.0
analyzer-0.41.25.2.0
args-2.3.12.3.1
async-2.10.02.10.0
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
collection-1.17.01.17.0
convert-2.1.13.1.1
crypto-2.1.53.0.2
file-6.1.46.1.4
glob-2.1.12.1.1
http-0.12.20.13.5
http_parser-3.1.44.0.2
isolate-2.1.12.1.1
json_rpc_2-2.2.23.0.2
package_config-1.9.32.1.0
pedantic-1.11.11.11.1
pointycastle-1.0.23.6.2
pub_semver-2.1.32.1.3
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
stream_channel-2.1.12.1.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
uuid-2.2.23.0.7
watcher-1.0.21.0.2
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint ^1.5.0 on build does not support the stable version 2.0.0.

Try running dart pub upgrade --major-versions build to update the constraint.

The constraint ^1.3.7 on dart_style does not support the stable version 2.0.0.

Try running dart pub upgrade --major-versions dart_style to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.10.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Dart 2.18.4.

8
likes
90
pub points
0%
popularity

Publisher

verified publisher iconsecure.vote

Generates dart classes corresponding to ABIs of Solidity smart contracts

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

build, dart_style, dartz, logging, meta, path, web3dart

More

Packages that depend on web3_contract_generator