wand 0.2.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 50

Pub Version Starware

Wand #

Wand is a command-line tool for generating boilerplate code for Flutter.
Create models, widgets, pages and blocs in a wink.

Installation #

  1. Install the Dart SDK.
  2. Install this package.
    $ pub global activate wand
    

Usage #

List available commands and subcommands.

$ wand -h
$ wand make -h

Generate classes (for example a model).

$ wand make model user

Starware #

Wand is Starware.
This means you're free to use the project, as long as you star its GitHub repository.
Your appreciation makes us grow and glow up. ⭐

Changelog #

0.2.1 - 2020-06-22 #

Fixed #

  • Bloc event and state stubs.

0.2.0 - 2020-05-31 #

Added #

  • Example.

Changed #

  • Replace repository with homepage in pubspec.yaml.
  • Update package description.

Fixed #

  • Refactor stub generation.

0.1.0 - 2020-05-31 #

Added #

  • Class make commands.

example/example.md

Example #

$ wand make model user
$ wand make page UserEdit
$ wand make bloc auth
$ wand make widget --stateful ImageCarousel

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate wand

2. Use it

The package has the following executables:


$ wand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  wand: ^0.2.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:wand/wand.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14

Analysis suggestions

Package not compatible with runtime flutter-web on web

Because:

  • package:wand/wand.dart that imports:
  • package:wand/commands/commands.dart that imports:
  • package:wand/commands/make_widget_subcommand.dart that imports:
  • package:wand/stubs/stubs.dart that imports:
  • package:wand/stubs/widget_stateless_stub.dart that imports:
  • package:wand/stubs/stub.dart that imports:
  • package:dart_style/dart_style.dart that imports:
  • package:dart_style/src/exceptions.dart that imports:
  • package:analyzer/error/error.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/source_io.dart that imports:
  • package:analyzer/src/generated/java_io.dart that imports:
  • dart:io

Package not compatible with runtime js

Because:

  • package:wand/wand.dart that imports:
  • package:wand/commands/commands.dart that imports:
  • package:wand/commands/make_widget_subcommand.dart that imports:
  • package:wand/stubs/stubs.dart that imports:
  • package:wand/stubs/widget_stateless_stub.dart that imports:
  • package:wand/stubs/stub.dart that imports:
  • package:dart_style/dart_style.dart that imports:
  • package:dart_style/src/exceptions.dart that imports:
  • package:analyzer/error/error.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/source_io.dart that imports:
  • package:analyzer/src/generated/java_io.dart that imports:
  • dart:io

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
args ^1.5.3 1.6.0
dart_style ^1.3.6 1.3.6
Transitive dependencies
_fe_analyzer_shared 5.0.0
analyzer 0.39.12
async 2.4.2
charcode 1.1.3
collection 1.14.13 1.15.0-nullsafety
convert 2.1.1
crypto 2.1.5
csslib 0.16.1
glob 1.2.0
html 0.14.0+3
js 0.6.2
meta 1.2.2 1.3.0-nullsafety
node_interop 1.1.1
node_io 1.1.1
package_config 1.9.3
path 1.7.0
pedantic 1.9.2
pub_semver 1.4.4
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0 1.3.0-nullsafety
watcher 0.9.7+15
yaml 2.2.1
Dev dependencies
effective_dart ^1.2.0
test ^1.6.0