walletconnect_dart 0.0.11 copy "walletconnect_dart: ^0.0.11" to clipboard
walletconnect_dart: ^0.0.11 copied to clipboard

Open protocol for connecting decentralised applications to mobile wallets with QR code scanning or deep linking.

111
likes
110/ 140
pub points
88%
popularity

We analyzed this package 30 hours ago, and awarded it 110 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/RootSoft/walletconnect-dart-sdk/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

78 out of 175 API elements (44.6 %) have documentation comments.

Some symbols that are missing documentation: walletconnect, walletconnect.CipherBox.decrypt, walletconnect.CipherBox.encrypt, walletconnect.CipherBox.generateKey, walletconnect.CipherBox.verifyHmac.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: This API is available since SDK 2.15.0, but constraints '>=2.14.0 <3.0.0' don't guarantee it.

lib/src/walletconnect.dart:394:5

    ╷
394 │     unawaited(_sendRequest(request));
    │     ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/walletconnect.dart

OK
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
convert ^3.0.1 3.1.1 3.1.1
cryptography ^2.0.5 2.7.0 2.7.0
json_annotation ^4.4.0 4.9.0 4.9.0
stack_trace ^1.10.0 1.11.1 1.11.1
uuid ^3.0.5 3.0.7 4.4.0
web_socket_channel ^2.1.0 2.4.5 3.0.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
js - 0.6.7 0.7.1
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
stream_channel - 2.1.2 2.1.2
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.5` on uuid does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

The constraint `^2.1.0` on web_socket_channel does not support the stable version `3.0.0`, that was published 16 days ago.

When web_socket_channel is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions web_socket_channel to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

111
likes
110
pub points
88%
popularity

Publisher

verified publisherkotapp.io

Open protocol for connecting decentralised applications to mobile wallets with QR code scanning or deep linking.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

convert, cryptography, json_annotation, stack_trace, uuid, web_socket_channel

More

Packages that depend on walletconnect_dart