vue_cli 0.4.1

  • Readme
  • Changelog
  • Installing
  • 43

vue_cli #

A CLI helper for VueDart, featuring project templates. See the VueDart site for details.

0.4.0 #

  • The version numbering has been changed to be in sync with VueDart.
  • Updates for VueDart 0.4.
  • The migrate command is now considered unsupported due to technical issues with it.

0.1.1 #

Use aspen_assets 0.2 instead of 0.1.

0.1.0 #


Use this package as an executable

1. Install it

You can install the package from the command line:

$ pub global activate vue_cli

2. Use it

The package has the following executables:

$ vuedart
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Nov 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21


Detected platforms: Flutter, web, other

No platform restriction found in libraries.

Health suggestions

Fix bin/vuedart.dart. (-12.22 points)

Analysis of bin/vuedart.dart reported 26 hints, including:

line 167 col 20: Unnecessary new keyword.

line 168 col 19: Unnecessary new keyword.

line 169 col 19: Unnecessary new keyword.

line 203 col 18: Unnecessary new keyword.

line 224 col 18: Unnecessary new keyword.

Maintenance suggestions

Package is getting outdated. (-10.41 points)

The package was last published 57 weeks ago.

The package description is too short. (-7 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
ansicolor ^1.0.1 1.0.2
args ^1.5.0 1.5.2
path ^1.6.2 1.6.4
source_maps ^0.10.6 0.10.8
source_span ^1.4.0 1.5.5
Transitive dependencies
charcode 1.1.2
term_glyph 1.1.0