voyager_bloc 0.5.0
voyager_bloc: ^0.5.0

Flutter Android iOS web

A BLoC plugin for Voyager. Allows describing used Blocs and their initial state in YAML config.

0
likes
90 / 110
pub points
29 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 16 API elements (6.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bloc^3.0.03.0.06.1.0
flutter_bloc^3.1.03.2.06.1.1
voyager^2.0.0+12.1.22.1.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
nested-0.0.40.0.4
path-1.7.01.8.0-nullsafety.3
provider-4.3.2+24.3.2+2
rxdart-0.23.10.24.1
source_span-1.7.01.8.0-nullsafety.4
sprintf-4.1.05.0.0
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.0` on bloc does not support the latest published version `6.1.0`

pubspec.yaml:13:9

   ╷
13 │   bloc: ^3.0.0
   │         ^^^^^^
   ╵
The constraint `^3.1.0` on flutter_bloc does not support the latest published version `6.1.1`

pubspec.yaml:14:17

   ╷
14 │   flutter_bloc: ^3.1.0
   │                 ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
90
pub points
29%
popularity

A BLoC plugin for Voyager. Allows describing used Blocs and their initial state in YAML config.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

luke.cherrish@gmail.com

License

MIT (LICENSE)

Dependencies

bloc, flutter, flutter_bloc, voyager

More

Packages that depend on voyager_bloc