vkio 1.1.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 59

vkio v1.1.0 #

A package which allows you to access to the VK API.

Features #

  • 100% coverage of the VK API

Usage #

import 'package:vkio/vk.dart';

main() {
  VK vk = new VK('a35e27fbb06d242fa72551433d2da1607035f6cdba1244cee86a3087bdfd32d54b8d1b6e6486c14c0ebe6');

  vk.api.messages.send({
    'user_id': 1,
    'message': 'Test',
  }).then((result) {
    print(result['response']);
  });
}

Changelog #

1.0.0 #

Initialize package

1.0.1 #

Add Utils methods support

Optimize classes

1.0.2-rc.1 #

Format files throught dartfmt Add example in example/

1.0.2 #

Add Account, Ads methods support

Optimize classes

1.1.0 #

Add 100% coverage of the VK API

Optimize classes

example/main.dart

import 'package:vkio/vk.dart';

VK vk = new VK(
    token:
        'a35e27fbb06d242fa72551433d2da1607035f6cdba1244cee86a3087bdfd32d54b8d1b6e6486c14c0ebe6',
    version: '5.98');

Future<void> main() async {
  /// Type of response is map because
  /// response is json decoded
  Map response = await vk.api.groups.getById();

  print(response);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  vkio: ^1.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:vkio/main.dart';
import 'package:vkio/models/account.dart';
import 'package:vkio/models/ads.dart';
import 'package:vkio/models/api.dart';
import 'package:vkio/models/apiexception.dart';
import 'package:vkio/models/apps.dart';
import 'package:vkio/models/auth.dart';
import 'package:vkio/models/board.dart';
import 'package:vkio/models/database.dart';
import 'package:vkio/models/docs.dart';
import 'package:vkio/models/fave.dart';
import 'package:vkio/models/friends.dart';
import 'package:vkio/models/gifts.dart';
import 'package:vkio/models/groups.dart';
import 'package:vkio/models/leads.dart';
import 'package:vkio/models/likes.dart';
import 'package:vkio/models/market.dart';
import 'package:vkio/models/messages.dart';
import 'package:vkio/models/newsfeed.dart';
import 'package:vkio/models/notes.dart';
import 'package:vkio/models/notifications.dart';
import 'package:vkio/models/orders.dart';
import 'package:vkio/models/pages.dart';
import 'package:vkio/models/photos.dart';
import 'package:vkio/models/polls.dart';
import 'package:vkio/models/prettycards.dart';
import 'package:vkio/models/search.dart';
import 'package:vkio/models/secure.dart';
import 'package:vkio/models/stats.dart';
import 'package:vkio/models/status.dart';
import 'package:vkio/models/storage.dart';
import 'package:vkio/models/stories.dart';
import 'package:vkio/models/streaming.dart';
import 'package:vkio/models/users.dart';
import 'package:vkio/models/utils.dart';
import 'package:vkio/models/video.dart';
import 'package:vkio/models/wall.dart';
import 'package:vkio/models/widgets.dart';
import 'package:vkio/vk.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
29
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
59
Learn more about scoring.

We analyzed this package on Oct 23, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:vkio/main.dart.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/nitreojs/dart-vkio was unreachable.

Issue tracker URL doesn't exist. (-10 points)

At the time of the analysis the issue_tracker field https://github.com/nitreojs/dart-vkio/issues was unreachable.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
html ^0.14.0+2 0.14.0+3
http ^0.12.0+2 0.12.0+2
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.12
csslib 0.16.1
http_parser 3.1.3
meta 1.1.7
path 1.6.4
pedantic 1.8.0+1
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6