vimeoplayer 0.1.8 icon indicating copy to clipboard operation
vimeoplayer: ^0.1.8 copied to clipboard

A new Flutter package for playing any videos from Vimeo by id.

48
likes
80/ 130
pub points
84%
popularity

We analyzed this package 1 hour ago, and awarded it 80 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 8 API elements (12.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:vimeoplayer/vimeoplayer.dart that imports:
  • package:vimeoplayer/src/fullscreen_player.dart that imports:
  • package:video_player/video_player.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:vimeoplayer/vimeoplayer.dart that imports:
  • package:vimeoplayer/src/fullscreen_player.dart that imports:
  • package:video_player/video_player.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:vimeoplayer/vimeoplayer.dart that imports:
  • package:vimeoplayer/src/fullscreen_player.dart that imports:
  • package:video_player/video_player.dart that declares support for platforms: Android, iOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:vimeoplayer/vimeoplayer.dart that imports:
  • package:vimeoplayer/src/fullscreen_player.dart that imports:
  • package:video_player/video_player.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: 'setEnabledSystemUIOverlays' is deprecated and shouldn't be used. Migrate to setEnabledSystemUIMode. This feature was deprecated after v2.3.0-17.0.pre..

lib/src/fullscreen_player.dart:88:20

   ╷
88 │       SystemChrome.setEnabledSystemUIOverlays([SystemUiOverlay.bottom]);
   │                    ^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/fullscreen_player.dart

INFO: 'setEnabledSystemUIOverlays' is deprecated and shouldn't be used. Migrate to setEnabledSystemUIMode. This feature was deprecated after v2.3.0-17.0.pre..

lib/src/fullscreen_player.dart:101:20

    ╷
101 │       SystemChrome.setEnabledSystemUIOverlays(
    │                    ^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/fullscreen_player.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
http^0.12.10.12.20.13.5
video_player>=0.10.0 <2.0.01.0.12.4.6
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.1
charcode-1.3.11.3.1
collection-1.16.01.16.0
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.44.0.1
js-0.6.40.6.4
material_color_utilities-0.1.40.2.0
meta-1.7.01.8.0
path-1.8.21.8.2
pedantic-1.11.11.11.1
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.2
video_player_platform_interface-2.2.05.1.4
video_player_web-0.1.4+12.0.12

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.1` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `>=0.10.0 <2.0.0` on video_player does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions video_player to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.14, Flutter 3.0.4, Dart 2.17.5.

48
likes
80
pub points
84%
popularity

Publisher

verified publisher iconprilogy.ru

A new Flutter package for playing any videos from Vimeo by id.

Homepage

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

flutter, http, video_player

More

Packages that depend on vimeoplayer