verify_email 0.0.3
verify_email: ^0.0.3 copied to clipboard

Verify an email address your user just entered. It's NOT encrypted but should do the job for most apps.

2
likes
90/ 130
pub points
24%
popularity

We analyzed this package 33 hours ago, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 4 API elements (25.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:verify_email/verify_email.dart that imports:
  • package:mailer/mailer.dart that imports:
  • package:mailer/src/smtp/mail_sender.dart that imports:
  • package:mailer/src/smtp/smtp_client.dart that imports:
  • package:mailer/src/smtp/internal_representation/internal_representation.dart that imports:
  • package:mailer/src/entities/message.dart that imports:
  • package:mailer/src/entities/attachment.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
mailer^3.2.13.3.05.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
intl-0.17.00.17.0
logging-0.11.41.0.2
meta-1.7.01.7.0
mime-0.9.71.0.1
path-1.8.01.8.0
pedantic-1.11.11.11.1
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.2.1` on mailer does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions mailer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

2
likes
90
pub points
24%
popularity

Publisher

hermannkabi.com

Verify an email address your user just entered. It's NOT encrypted but should do the job for most apps.

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, mailer

More

Packages that depend on verify_email