velocity_x 1.4.1 icon indicating copy to clipboard operation
velocity_x: ^1.4.1 copied to clipboard

A minimalist Flutter framework for rapidly building custom designs.

828
likes
100/ 130
pub points
97%
popularity

We analyzed this package 6 days ago, and awarded it 100 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 1180 out of 2765 API elements (42.7 %) have documentation comments.
icon indicating section status
Platform Support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
animator^2.0.22.0.23.1.0
auto_size_text^2.1.02.1.03.0.0
flutterflutter0.0.00.0.0
intl^0.16.10.16.10.17.0
vxstate^1.0.11.0.12.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
path-1.8.11.8.1
sky_engine-0.0.990.0.99
states_rebuilder-3.2.05.2.0
typed_data-1.3.01.3.0
vector_math-2.1.12.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^2.0.2` on animator does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions animator to update the constraint.

The constraint `^2.1.0` on auto_size_text does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions auto_size_text to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.5, Flutter 2.8.1, Dart 2.15.1.

828
likes
100
pub points
97%
popularity

Publisher

shield icon for verified publisherscodepur.dev

A minimalist Flutter framework for rapidly building custom designs.

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

unknown (LICENSE)

Dependencies

animator, auto_size_text, flutter, intl, vxstate

More

Packages that depend on velocity_x