veev_widgets 0.0.3
veev_widgets: ^0.0.3 copied to clipboard

A new Flutter package project.

0
likes
60/ 130
pub points
23%
popularity

We analyzed this package on Sep 28, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.
The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 50 API elements (8.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Android`.

Because:

  • package:veev_widgets/veev_widgets.dart that imports:
  • package:veev_widgets/src/custom_scaffold/custom_scaffold.dart that imports:
  • package:bitsdojo_window/bitsdojo_window.dart that declares support for platforms: Windows, Linux, macOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bitsdojo_window^0.0.30.0.90.1.1+1
flutterflutter0.0.00.0.0
flutter_mobxany2.0.22.0.2
mobxany2.0.42.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
bitsdojo_window_linux-0.0.10.1.1
bitsdojo_window_macos-0.0.30.1.0
bitsdojo_window_platform_interface-0.0.20.1.0
bitsdojo_window_windows-0.0.30.1.0
characters-1.1.01.2.0
collection-1.15.01.15.0
ffi-1.1.21.1.2
meta-1.7.01.7.0
plugin_platform_interface-1.0.32.0.1
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.2.92.2.9

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.0.3` on bitsdojo_window does not support the stable version `0.1.0`.

Try running dart pub upgrade --major-versions bitsdojo_window to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.1+1, Flutter 2.5.0, Dart 2.14.0.

0
likes
60
pub points
23%
popularity

A new Flutter package project.

Documentation

API reference

License

unknown (LICENSE)

Dependencies

bitsdojo_window, flutter, flutter_mobx, mobx

More

Packages that depend on veev_widgets