vector_graphics_compiler 1.1.11+1 copy "vector_graphics_compiler: ^1.1.11+1" to clipboard
vector_graphics_compiler: ^1.1.11+1 copied to clipboard

A compiler for `package:vector_graphics`.

29
likes
120/ 140
pub points
97%
popularity

We analyzed this package 37 hours ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

362 out of 367 API elements (98.6 %) have documentation comments.

Some symbols that are missing documentation: vector_graphics_compiler, vector_graphics_compiler.PathBuilder.close, vector_graphics_compiler.PathBuilder.cubicTo, vector_graphics_compiler.PathBuilder.lineTo, vector_graphics_compiler.PathBuilder.moveTo.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.3.0 2.5.0 2.5.0
meta ^1.7.0 1.14.0 1.14.0
path ^1.8.0 1.9.0 1.9.0
path_parsing ^1.0.1 1.0.1 1.0.1
vector_graphics_codec 1.1.11+1 1.1.11+1 1.1.11+1
xml ^6.3.0 6.5.0 6.5.0
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
petitparser - 6.0.2 6.0.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.