vault 0.0.3
vault: ^0.0.3 copied to clipboard

Save key value pairs securely

5
likes
100/ 130
pub points
0%
popularity

We analyzed this package on Sep 22, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 8 API elements (62.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:vault/vault.dart that imports:
  • package:vault/src/locker.dart that imports:
  • package:flutter_secure_storage/flutter_secure_storage.dart that declares support for platforms: Android, iOS, Linux.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/locator.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/vault.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_secure_storage^4.2.04.2.14.2.1
get_it^7.1.37.2.07.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.1+1, Flutter 2.5.0, Dart 2.14.0.

5
likes
100
pub points
0%
popularity

Publisher

unengineered.net

Save key value pairs securely

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_secure_storage, get_it

More

Packages that depend on vault