Lightweight library for validating function arguments in Dart.
This library is mainly a port of Apaches org.apache.commons.lang3.Validate class
Validation is necessary on most public-facing APIs. Parameter validation on non-public methods is not as important - it is often desirable to have validation occur only once, at the public 'entry point' - but if you can live with the potential performance hit, I recommend to validate parameters everywhere, as it makes code maintenance and refactoring a bit easier.
For further documentation please refere to the Unit-Tests.
- 1.4.0 - Instance check added
- 1.3.0 - Validate.isUUID added
- 1.2.7 - Removed debug info from URIBuilder
- 1.2.4 - Runs with Dart 1.1 + IntelliJ 13
- 1.2.0 - isKeyInMap check added
- 1.1.0 - isJson check added
- 1.0.5 - Changed GitHub-Repository to dart-validate
- 1.0.4 - Replaced NullPointerException with ArgumentError - makes more sense
Copyright 2013 Michael Mitterer, IT-Consulting and Development Limited, Austrian Branch Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at http://www.apache.org/licenses/LICENSE-2.0 Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.
If this plugin is helpful for you - please (Circle) me.
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: validate: ^1.4.1
2. Install it
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Analysis issues and suggestions
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.