user_messaging_platform 1.3.0 copy "user_messaging_platform: ^1.3.0" to clipboard
user_messaging_platform: ^1.3.0 copied to clipboard

A plugin which provides a Dart API for the User Messaging Platform (UMP) SDK, which is the Consent Management Platform (CMP) SDK provided as part of Google's Funding Choices.

27
likes
130/ 140
pub points
90%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/blaugold/user_messaging_platform/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

46 out of 47 API elements (97.9 %) have documentation comments.

Some symbols that are missing documentation: user_messaging_platform.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:user_messaging_platform/user_messaging_platform.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:user_messaging_platform/user_messaging_platform.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:user_messaging_platform/user_messaging_platform.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:user_messaging_platform/user_messaging_platform.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The import of 'package:meta/meta.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/foundation.dart'.

lib/user_messaging_platform.dart:5:8

  ╷
5 │ import 'package:meta/meta.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/user_messaging_platform.dart

INFO: 'describeEnum' is deprecated and shouldn't be used. Use the `name` getter on enums instead. This feature was deprecated after v3.14.0-2.0.pre.

lib/user_messaging_platform.dart:432:41

    ╷
432 │     enumValues.firstWhereOrNull((it) => describeEnum(it) == valueName);
    │                                         ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/user_messaging_platform.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.18.0 1.18.0
flutter flutter 0.0.0 0.0.0
meta ^1.3.0 1.11.0 1.12.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
material_color_utilities - 0.8.0 0.8.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

27
likes
130
pub points
90%
popularity

Publisher

verified publishergabriel.terwesten.net

A plugin which provides a Dart API for the User Messaging Platform (UMP) SDK, which is the Consent Management Platform (CMP) SDK provided as part of Google's Funding Choices.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, flutter, meta

More

Packages that depend on user_messaging_platform