usb_serial 0.4.0 icon indicating copy to clipboard operation
usb_serial: ^0.4.0 copied to clipboard

PlatformAndroid

This plugin will allow you to easily use the USB uart hardware based on FTDI or CDC (and more!) protocols.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add usb_serial

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  usb_serial: ^0.4.0

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:usb_serial/usb_serial.dart';
102
likes
130
pub points
93%
popularity

Publisher

verified publisher iconbessems.dev

This plugin will allow you to easily use the USB uart hardware based on FTDI or CDC (and more!) protocols.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

async, collection, flutter

More

Packages that depend on usb_serial