urbit_ob 1.0.0
urbit_ob: ^1.0.0 copied to clipboard

A starting point for Dart libraries or applications.

0
likes
70/ 130
pub points
0%
popularity

We analyzed this package on Oct 26, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 30 API elements (30.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/src/helpers.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/muk.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
logging^0.11.30.11.41.0.2
pointycastle^1.0.11.0.23.3.4
quiver>=2.0.0 <3.0.02.1.53.0.1+1
Transitive dependencies
PackageConstraintCompatibleLatest
matcher-0.12.110.12.11
meta-1.7.01.7.0
path-1.8.01.8.0
stack_trace-1.10.01.10.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.11.3` on logging does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions logging to update the constraint.

The constraint `^1.0.1` on pointycastle does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions pointycastle to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.5.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.

0
likes
70
pub points
0%
popularity

Publisher

bydot.app

A starting point for Dart libraries or applications.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

logging, pointycastle, quiver

More

Packages that depend on urbit_ob