update_app 0.0.5

  • Readme
  • Changelog
  • Example
  • Installing
  • 59

update_app #

更新app, 传入更新的地址, 进行app更新, Android部分使用DownloadManager实现.若文件已下载, 则直接安装.
Ios部分不支持外部更新, 跳转App Store.

体验demo #

apk下载

screen

使用方法 #

import 'package:update_app/update_app.dart';

UpdateApp.updateApp(url: "apkPath",appleId:"375380948",title:"通知标题",description:"通知描述");

特点 #

Android部分 #

  1. 使用DownloadManager进行下载
  2. 监听下载完成广播
  3. 适配Android 6.0运行时权限 文件存储在app目录, 不需要申请运行时权限
  4. 适配Android 7.0FileProvider
  5. 适配Android 8.0安装权限
  6. 适配Android 9.0网络安全配置

IOS部分 #

  1. 跳转应用商店

0.0.1 #

  1. 使用DownloadManager进行下载
  2. 监听下载完成广播
  3. 适配Android 6.0运行时权限 文件存储在app目录, 不需要申请运行时权限
  4. 适配Android 7.0FileProvider
  5. 适配Android 8.0安装权限
  6. 适配Android 9.0网络安全通信

0.0.2 #

未修改

0.0.3 #

  1. 完成IOS部分, 跳转Apple Store

0.0.4 #

  1. 修复bug

0.0.5 #

1.修改版本问题

example/README.md

update_app_example #

Demonstrates how to use the update_app plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  update_app: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:update_app/update_app.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
26
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
59
Learn more about scoring.

We analyzed this package on Oct 9, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The description is too long. (-10 points)

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test