unsure 0.1.2
unsure: ^0.1.2 copied to clipboard

An easy to use probabilistic notation, and a package that can parse it and calculate with it.

1
likes
100/ 130
pub points
0%
popularity

We analyzed this package 6 hours ago, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 41 API elements (26.8 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.5.21.6.02.3.0
petitparser>=2.4.0 <4.0.03.1.04.4.0
t_stats^2.1.02.1.1+13.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
matcher-0.12.110.12.11
meta-1.7.01.7.0
path-1.8.01.8.0
quiver-2.1.53.0.1+1
stack_trace-1.10.01.10.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.5.2` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `>=2.4.0 <4.0.0` on petitparser does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions petitparser to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.3.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

1
likes
100
pub points
0%
popularity

Publisher

filiph.net

An easy to use probabilistic notation, and a package that can parse it and calculate with it.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

args, petitparser, t_stats

More

Packages that depend on unsure