universal_io 2.2.2 copy "universal_io: ^2.2.2" to clipboard
universal_io: ^2.2.2 copied to clipboard

Cross-platform 'dart:io' that adds browser support for HttpClient and some other "dart:io" APIs.

226
likes
160/ 160
pub points
98%
popularity

We analyzed this package 14 hours ago, and awarded it 160 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

23 out of 24 API elements (95.8 %) have documentation comments.

Some symbols that are missing documentation: universal_io.BrowserHttpClient.BrowserHttpClient.constructor.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:universal_io/io.dart that imports:
  • package:universal_io/src/_exports_in_browser.dart that imports:
  • package:universal_io/src/internet_address.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.17.0 1.19.0 1.19.0
meta ^1.9.0 1.15.0 1.15.0
typed_data ^1.3.0 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.

226
likes
160
pub points
98%
popularity

Publisher

verified publisherdint.dev

Cross-platform 'dart:io' that adds browser support for HttpClient and some other "dart:io" APIs.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (license)

Dependencies

collection, meta, typed_data

More

Packages that depend on universal_io