twitter_kit 0.2.0 icon indicating copy to clipboard operation
twitter_kit: ^0.2.0 copied to clipboard

Project to make it easier to access the Twitter API. Referring to the Twitter kit for Android.

2
likes
100/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 164 out of 400 API elements (41.0 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform Windows.

Because:

  • package:twitter_kit/twitter_kit.dart that declares support for platforms: Android, iOS.

Package does not support platform Linux.

Because:

  • package:twitter_kit/twitter_kit.dart that declares support for platforms: Android, iOS.

Package does not support platform macOS.

Because:

  • package:twitter_kit/twitter_kit.dart that declares support for platforms: Android, iOS.

Package does not support platform Web.

Because:

  • package:twitter_kit/twitter_kit.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

INFO: The import of 'package:twitter_kit/src/services/model/favorite_create_body.dart' is unnecessary because all of the used elements are also provided by the import of 'package:twitter_kit/twitter_kit.dart'.

lib/src/services/favorite_service.dart:3:8

  ╷
3 │ import 'package:twitter_kit/src/services/model/favorite_create_body.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/services/favorite_service.dart

INFO: The import of 'package:twitter_kit/src/services/model/favorite_destroy_body.dart' is unnecessary because all of the used elements are also provided by the import of 'package:twitter_kit/twitter_kit.dart'.

lib/src/services/favorite_service.dart:4:8

  ╷
4 │ import 'package:twitter_kit/src/services/model/favorite_destroy_body.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/services/favorite_service.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
chopper^3.0.23.0.65.1.0
flutterflutter0.0.00.0.0
json_annotation^3.0.13.1.14.7.0
oauth1^1.0.41.0.62.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
charcode-1.3.11.3.1
collection-1.16.01.17.0
convert-2.1.13.1.1
crypto-2.1.53.0.2
http-0.12.20.13.5
http_parser-3.1.44.0.2
logging-0.11.41.1.0
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
path-1.8.21.8.2
pedantic-1.11.11.11.1
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint ^3.0.2 on chopper does not support the stable version 4.0.0.

Try running dart pub upgrade --major-versions chopper to update the constraint.

The constraint ^3.0.1 on json_annotation does not support the stable version 4.0.0.

Try running dart pub upgrade --major-versions json_annotation to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.1.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

2
likes
100
pub points
0%
popularity

Publisher

verified publisher iconkitproject.info

Project to make it easier to access the Twitter API. Referring to the Twitter kit for Android.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

Dependencies

chopper, flutter, json_annotation, oauth1

More

Packages that depend on twitter_kit