twicon 0.1.1

  • Readme
  • Changelog
  • Example
  • Installing
  • new65

twicon #

twicon helps to integrate TW Icon Fonts, into your Flutter apps,

TW Icon Fonts consist of free icons covering topics like sights, products, traffic and so on. They let you to promote your favorite places and cuisines in Taiwan easily.

The icons are designed by a Japanese designer, holoko, and an English designer Rob. They are both living in Taiwan right now. For further information, please visit TW Icon Fonts.

Usage #

Adds twicon to your pubspec file, run futter packages get, then you can import the package:

import 'package:twicon/twicon.dart';

Then you can use these icons in widgets like Icon, IconButton and so on:

Icon(TaiwanIcons.taipei101);

You can also run the example project, to view the icons included.

screenshot.png

0.1.1 #

  • Updates license and documentation.

0.1.0 #

  • The initial release.

example/README.md

example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  twicon: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:twicon/twicon.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
30
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
65
Learn more about scoring.

We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test