tweet_webview 0.2.2
tweet_webview: ^0.2.2

Flutter Android iOS

A Flutter widget to display a Twitter tweet in a WebView widget using webview_flutter.

6
likes
80 / 110
pub points
73 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 6 API elements (16.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:tweet_webview/tweet_webview.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.0+20.12.20.12.2
path_provider^1.5.11.6.241.6.24
webview_flutter^0.3.14+10.3.241.0.7
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
ffi-0.1.30.1.3
file-5.2.15.2.1
http_parser-3.1.43.1.4
intl-0.16.10.16.1
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.7.01.8.0-nullsafety.3
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+60.0.4+6
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
pedantic-1.9.21.9.2
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
source_span-1.7.01.8.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.3.14+1` on webview_flutter does not support the latest published version `1.0.7`

pubspec.yaml:15:20

   ╷
15 │   webview_flutter: ^0.3.14+1
   │                    ^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

6
likes
80
pub points
73%
popularity

A Flutter widget to display a Twitter tweet in a WebView widget using webview_flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

larryaasen@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, http, path_provider, webview_flutter

More

Packages that depend on tweet_webview