tribally_sdk 0.1.0 copy "tribally_sdk: ^0.1.0" to clipboard
tribally_sdk: ^0.1.0 copied to clipboard

PlatformiOS

Tribally SDKs enable your users to create communities and bring in more people to talk about the things they love.

6
likes
110/ 140
pub points
0%
popularity

We analyzed this package 17 hours ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

2 out of 32 API elements (6.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: tribally_sdk, tribally_sdk.ApiProject, tribally_sdk.ApiProject.ApiProject, tribally_sdk.ApiProject.api, tribally_sdk.ApiProject.id.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ iOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:tribally_sdk/tribally_sdk.dart that declares support for platforms: iOS.
Package does not support platform `Windows`.

Because:

  • package:tribally_sdk/tribally_sdk.dart that declares support for platforms: iOS.
Package does not support platform `Linux`.

Because:

  • package:tribally_sdk/tribally_sdk.dart that declares support for platforms: iOS.
Package does not support platform `macOS`.

Because:

  • package:tribally_sdk/tribally_sdk.dart that declares support for platforms: iOS.
Package does not support platform `Web`.

Because:

  • package:tribally_sdk/tribally_sdk.dart that declares support for platforms: iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

WARNING: The value of the field '_triballyViewState' isn't used.

lib/tribally_controller.dart:9:28

  ╷
9 │   final _TriballyViewState _triballyViewState;
  │                            ^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/tribally_controller.dart

INFO: The part-of directive uses a library name.

lib/extentions/color_extention.dart:1:1

  ╷
1 │ part of tribally_sdk;
  │ ^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/extentions/color_extention.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

6
likes
110
pub points
0%
popularity

Publisher

unverified uploader

Tribally SDKs enable your users to create communities and bring in more people to talk about the things they love.

Homepage

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on tribally_sdk