translate 1.0.0
translate: ^1.0.0 copied to clipboard

Dart native
Flutter Android iOS

A simple to use Dart package, for translating text using Yandex.Translate API

4
likes
90 / 110
pub points
53 %
popularity

We analyzed this package on Jan 11, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 30 API elements (20.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:translate/translate.dart that imports:
  • package:translate/src/translate_it.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

INFO: Use `=` to separate a named parameter from its default value.

lib/src/detect_it.dart:16:16

   ╷
16 │     this.domain: 'translate.yandex.net',
   │                ^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/detect_it.dart

INFO: Use `=` to separate a named parameter from its default value.

lib/src/detect_it.dart:17:14

   ╷
17 │     this.path: '/api/v1.5/tr.json/detect',
   │              ^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/detect_it.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

4
likes
90
pub points
53%
popularity

Publisher

itzmeanjan.in

A simple to use Dart package, for translating text using Yandex.Translate API

Homepage

Documentation

API reference

License

MIT (LICENSE)

More

Packages that depend on translate