toughpad 1.0.1

Flutter Android iOS

Panasonic Toughpad plugin.

0
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Oct 29, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 10 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:toughpad/toughpad.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:toughpad/toughpad.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:toughpad/toughpad.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:toughpad/toughpad.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
rxdart^0.21.00.21.00.24.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0-nullsafety.4
collection-1.15.0-nullsafety.31.15.0-nullsafety.4
meta-1.3.0-nullsafety.31.3.0-nullsafety.5
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.4
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.4

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.21.0` on rxdart does not support the latest published version `0.24.1`

pubspec.yaml:13:11

   ╷
13 │   rxdart: ^0.21.0
   │           ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
0%
popularity

Panasonic Toughpad plugin.

Homepage

Documentation

API reference

Uploader

andrewmacaulay@gmail.com

License

unknown (LICENSE)

Dependencies

flutter, rxdart

More

Packages that depend on toughpad