tota 0.6.2 icon indicating copy to clipboard operation
tota: ^0.6.2 copied to clipboard

SDKDart

A simple and elegant framework for generating static sites. Great for personal websites, blogs, documentation, and more.

1
likes
70/ 130
pub points
0%
popularity

We analyzed this package 8 hours ago, and awarded it 70 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 41 out of 61 API elements (67.2 %) have documentation comments.
icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:tota/tota.dart that imports:
  • package:tota/src/tota.dart that imports:
  • package:tota/src/resource.dart that imports:
  • package:tota/src/file_system.dart that imports:
  • package:mustache/mustache.dart that imports:
  • package:mustache/src/template.dart that imports:
  • package:mustache/src/renderer.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:tota/tota.dart that imports:
  • package:tota/src/tota.dart that imports:
  • package:tota/src/resource.dart that imports:
  • package:tota/src/file_system.dart that imports:
  • package:mustache/mustache.dart that imports:
  • package:mustache/src/template.dart that imports:
  • package:mustache/src/renderer.dart that imports:
  • dart:mirrors
Package not compatible with platform Windows

Because:

  • package:tota/tota.dart that imports:
  • package:tota/src/tota.dart that imports:
  • package:tota/src/resource.dart that imports:
  • package:tota/src/file_system.dart that imports:
  • package:mustache/mustache.dart that imports:
  • package:mustache/src/template.dart that imports:
  • package:mustache/src/renderer.dart that imports:
  • dart:mirrors
Package not compatible with platform Linux

Because:

  • package:tota/tota.dart that imports:
  • package:tota/src/tota.dart that imports:
  • package:tota/src/resource.dart that imports:
  • package:tota/src/file_system.dart that imports:
  • package:mustache/mustache.dart that imports:
  • package:mustache/src/template.dart that imports:
  • package:mustache/src/renderer.dart that imports:
  • dart:mirrors
Package not compatible with platform macOS

Because:

  • package:tota/tota.dart that imports:
  • package:tota/src/tota.dart that imports:
  • package:tota/src/resource.dart that imports:
  • package:tota/src/file_system.dart that imports:
  • package:mustache/mustache.dart that imports:
  • package:mustache/src/template.dart that imports:
  • package:mustache/src/renderer.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:tota/tota.dart that imports:
  • package:tota/src/tota.dart that imports:
  • package:tota/src/starter.dart that imports:
  • package:tota/src/exceptions.dart that imports:
  • package:tota/src/deploy/deploy.dart that imports:
  • package:tota/src/deploy/netlify/netlify_deploy_handler.dart that imports:
  • package:tota/src/deploy/netlify/netlify_site.dart that imports:
  • package:tota/src/deploy/netlify/netlify_client.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: The import of '../config.dart' is unnecessary because all of the used elements are also provided by the import of '../../tota.dart'.

lib/src/commands/build.dart:7:8

  ╷
7 │ import '../config.dart';
  │        ^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/commands/build.dart

INFO: The import of '../config.dart' is unnecessary because all of the used elements are also provided by the import of '../../tota.dart'.

lib/src/commands/deploy.dart:6:8

  ╷
6 │ import '../config.dart';
  │        ^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/commands/deploy.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.5.21.6.02.3.1
cli_util^0.1.3+20.1.40.3.5
crypto^2.0.62.1.53.0.2
front_matter^1.1.01.1.01.1.0
http^0.12.0+20.12.20.13.4
intl^0.15.80.15.80.17.0
markdown^2.0.32.1.85.0.0
meta^1.1.71.8.01.8.0
mustache^1.1.11.1.11.1.1
path^1.6.21.8.21.8.2
pool^1.4.01.5.11.5.1
slugify^1.0.01.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.9.02.9.0
charcode-1.3.11.3.1
collection-1.16.01.16.0
convert-2.1.13.0.2
http_parser-3.1.44.0.1
pedantic-1.11.11.11.1
source_span-1.9.01.9.0
stack_trace-1.10.01.10.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
yaml-2.2.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^1.5.2` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^0.1.3+2` on cli_util does not support the stable version `0.2.0`.

Try running dart pub upgrade --major-versions cli_util to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.3.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.13, Dart 2.17.5.

1
likes
70
pub points
0%
popularity

Publisher

unverified uploader

A simple and elegant framework for generating static sites. Great for personal websites, blogs, documentation, and more.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

args, cli_util, crypto, front_matter, http, intl, markdown, meta, mustache, path, pool, slugify

More

Packages that depend on tota